18 de fev de 2011

Instalando a Impressora e o Scanner Epson Stylus TX125 no Ubuntu


ATENÇÃO!!! Não é mais necessária a instalação do driver do scanner e da impressora a partir do Ubuntu 14.10, sendo necessário apenas clicar em Adicionar no menu Impressoras no Configurações do Sistema.

Veja como verificar o nível de tinta em: http://alinetux.blogspot.com/2015/06/como-verificar-o-nivel-de-tinta-da.html

Configuração para Ubuntu 14.04 ou anterior:


Só ligue a impressora quando o Ubuntu terminar de iniciar. Irá aparecer uma notificação avisando que driver da impressora está faltando.

Se não aparecer vá em Sistema -> Administração -> Impressão. Na janela que abrir clique em adicionar. Na proxima janela voce terá de encontrar a impressora, se ela estiver na rede clique em localizar impressora na rede.

Clique para ampliar
Na próxima janela selecione a opção selecionar impressora da base de dados, e na lista selecione Epson e clique em Avançar.


Escolha o driver Stylus TX110 e clique em avançar.


Agora escolha um nome para a impressora (os últimos dois campos podem ficar em branco) e clique em Aplicar.


Para instalar o scanner é necessário a instalação do Image Scan. A partir do Ubuntu 11.10 é necessário instalar o pacote xsltproc antes:

sudo apt-get install xsltproc

Agora baixe estes arquivos:

Programa: iscan-data_1.22.0-1_all.deb

Driver: 32 bits iscan_2.29.1-5~usb0.1.ltdl7_i386.deb
               64 bits iscan_2.29.1-5~usb0.1.ltdl7_amd64.deb

Mova os arquivos para a raíz do diretório pessoal (/home/seu_usuario). Desligue a impressora e execute estes comandos no terminal:
sudo dpkg --install iscan-data_1.22.0-1_all.deb

Se seu PC for 32 bits:
sudo dpkg --install iscan_2.29.1-5~usb0.1.ltdl7_i386.deb

Para os 64 bits:
sudo dpkg --install iscan_2.29.1-5~usb0.1.ltdl7_amd64.deb para pcs 64 bits

Ligue a impressora e abra o programa Image Scan! (Aplicativos -> Gráficos -> Image Scan! for Linux).

Se ocorrer algum erro desligue a impressora e repita os comandos.

Image Scan!

Dúvidas? Comente abaixo!

27 comentários:

  1. gracias hace mucho que lo intentaba pero ahora anduvo bien de bien

    ResponderExcluir
  2. Perfeito depois de me matar tentando fazer funcionar o scanner da minha TX125 aqui foi o unico lugar que achei e que funcionou brigado ótimo post@

    ResponderExcluir
  3. Meu nome é Walter - email wdgomes@hotmail.com

    Ótimo, funcionou de primeira.
    Porém você poderia escrever também para os iniciantes.
    Comprei Três impressoras desta, um para meu amigo, um para minha casa e outra para o C. E. Que frequento.

    Muito Obrigado !!!!

    ResponderExcluir
  4. Desculpe, mas acho que já está bem fácil até para iniciantes. A impressora se instala quase que sozinha e o scanner deve ser instalado pelo terminal mesmo.

    ResponderExcluir
  5. Grato pela dica e parabéns pela iniciativa.

    ResponderExcluir
  6. Consegui instalar também o scanner da minha impressora, obrigado pelo post foi muito intuitivo, só acrescentando quem estiver usando o ubuntu\kubuntu 64btis deverá baixar o pacote iscan_2.28.1-3.ltdl7_amd64.deb em vez do pacote i386 acima citado.

    ResponderExcluir
    Respostas
    1. Obrigada pela dica! Vai ajudar os próximos usuários (ou roots!)

      Excluir
  7. OLA PARA INSTALAR O SCCANER DA TX 300F NO UBUNTO 11.10 DEVO SEGUIR O MESMO PROCEDIMENTO?

    AGRADEÇO SE PUDER CONTRIBUIR, TO NA LUTA!

    ResponderExcluir
  8. BOM DIA!

    PARA INSTALAR O SCANNER DA EPSON TX 300F NO UBUNTU 11.10 PODERIA SEGUIR O MESMO PROCEDIMENTO?
    O DRIVE DA IMPRESSORA ELE RECONHECEU AUTOMATICAMENTE AO INSTALAR MAS O SCANNER ATE AGORA NÃO CONSEGUI. ACHEI SEU LINK NO FÓRUM...

    DESDE JÁ OBRIGADO PELA PRONTIDÃO EM AJUDAR

    ResponderExcluir
  9. Olá Aline,
    Para instalar o scanner TX115 é o mesmo procedimento? Não entendi qdo vc diz para "mover para a pasta pessoal". O q é isso?

    ResponderExcluir
    Respostas
    1. É o mesmo procedimento. É para tirar da pasta de download e deixar na sua pasta principal, tipo o "Meus documentos" do Windows.

      Excluir
  10. Os drivers para scanners da Epson estão no site: http://www.avasys.jp/lx-bin2/linux_e/spc/DL1.do - Não sei se tem para o modelo TX300F

    ResponderExcluir
  11. Esses procedimentos funciona em uma plataforma 64?

    ResponderExcluir
  12. Valeu, Aline!
    Obrigado e parabéns!
    Funcionou na distro (brasileira) BigLinux, que é baseada no Ubuntu!
    Sucesso!
    Abração!
    Rogério.

    ResponderExcluir
  13. Salvou minha vida xará! Detalhe: funciona para tx220 tbm, talvez funcione p outras :)
    Um abraço!

    ResponderExcluir
  14. Aline, você é 10! Beijos.

    ResponderExcluir
  15. Oi Aline, achei um site da Epson com drivers para Linux.
    http://download.ebz.epson.net/dsc/search/01/search/
    E parabéns pela ajuda.

    ResponderExcluir
  16. Aline ... vlw ... Deus abençoe sempre esta sua atitude em partilhar conhecimento

    ResponderExcluir
  17. Não acredito, funcionou de primeira. Muito obrigado!!!

    ResponderExcluir
  18. Tentei várias vezes e o sistema fica instalando... trava... não sei o que fazer mais. Funcionava tão bem no 12.4. Agora com o 14.4 está acontecendo umas coisas estranhas: a tela fica toda embaçada, que eu não sei onde está nada: minimizar,maximizar e fechar... Que será isso?

    ResponderExcluir
    Respostas
    1. Leni, use a versão mais recente, 16.04. A 14.04 não tem mais suporte.
      Se continuar com problema me retorne.

      Excluir
  19. Leni, use a versão mais recente, 16.04. A 14.04 não tem mais suporte.
    Se continuar com problema me retorne.

    ResponderExcluir
  20. Desculpe, Aline, mas o suporte do 12.04 vai até 2017. o 14:4 é até 2019, se não me engano. Eu sempre uso uma versão depois que já está estável, por isso estou usando a 14.04. Eu já consegui instalar o drive pelo synaptic. Minha impressora está funcionando. Preciso fazer funcionar o scaner.

    ResponderExcluir
  21. Para solucionar o problema do scanner, lembro que na época tive que instalar o xsltproc (conforme descrito no post).
    Como prefere usar versões antigas, recomendo que pelo menos use a versão 14.10 que não necessita nenhuma instalação ou configuração para o uso da TX125.
    Versões antigas não tem suporte completo, a 14.04 por exemplo não terá mais atualizações para hardware a partir de agosto deste ano, veja mais em: http://www.ubuntu.com/info/release-end-of-life
    Após umas duas semanas de lançamento a versão já está bem estável. Às vezes uso as de pré-lançamento também sem problemas.
    A Canonical, eu e um amigo meu que trabalha com vulnerabilidades, recomendamos sempre usar a versão mais nova por segurança. Já conheci gente que teve os dados roubados, Ubuntu se torna mais vulnerável por ser uma distribuição bem conhecida.
    Fora que a integração com a interface Unity é péssima, acho que eles só começaram a fazer direito a partir do ano passado. Que saudade do Gnome...

    ResponderExcluir